Overview

The SystemWeaver Explorer (swExplorer) application has a user interface optimized for navigating and viewing content. This article will introduce you to the standard interface and where to perform some common tasks. This article focuses mainly on the interface as seen from the Items Ribbon tab.


Tip: Due to the large amount of information that the application has to display, it is recommended that you run it with your screen maximized on your desktop.


Introduction

SystemWeaver Explorer consists of these main parts:

  • Item Structure Tree
  • Specification View
  • Menu Tabs and Ribbons
  • Title Bar
  • Status Bar


The structure tree and specification view panes can be resized by dragging or double-clicking on the pane divider: 



Often, the simple act of resizing to give more screen real estate to the specification view can significantly improve the appearance of a view containing a large number of charts, for example.


Note: Each time you log in to a SystemWeaver server all layout settings from your most recent login session are restored.


The Structure Tree

The structure tree is a view that shows the structure of the items that you are working with. The structure follows a meta model which is a set of rules for a SystemWeaver database that specify the item types, part types, attribute types, etc. that are going to be used for a particular SystemWeaver installation. The meta model is designed by a user that has Architect rights to the system and it dictates how you can work with the items. When viewing the tree, there will always be a top item for the structure you are viewing. Then, if an item is associated or related to another item, you will see the relationship, also known as a part, visualized as a link to the other item. Items can also be parts, i.e., a sub-item of another item. 


The structure tree is a useful projection of the model. The icons you see in the tree are predefined and represent the type of item. The structure tree can be configured to show or hide certain items, either by choosing a globally predefined setting for your view or by modifying it to fit your needs for the moment. This gives you the flexibility to either focus specifically on what you are working on without a lot of other noise or to expand and see relationships as needed.


Example:

An example item structure is illustrated below and a brief description of items and parts will help you understand the structure. A car has four wheels and the relationship between the car and each wheel is unique. This relationship is called a part in SystemWeaver. Items can also be parts. For example, a wheel is an item just as the car is an item, yet the wheels are a part of the car.



In the structure tree view, the above structure would appear like this (disregard the specific icons seen here):


The item at the top of the tree - in this case "Item A" - is referred to as the "top item" of the tree. Each tree node below the top node represents both a specific part (relationship) and the item of the part.


Viewing Occurrences of a Part

To view the reuse of a simple part in the tree, select one of them and press Ctrl+C (to copy it to clipboard) and then Ctrl+G to visually find all of the occurrences in the tree. They will all appear highlighted in green. Below, the "Adjust speed" requirement is reused twice in the structure: 



The Find tool will be explained more in The Menu Tabs and Ribbons section below. 


Global Settings

Site-wide settings are accessed by clicking on the structure tree name at the top of the tree. The available, predefined view options will display. Globally defined options are configured by users with the SystemWeaver Architect role. You can always see which view is currently applied as its name displays directly to the right of the tree name. In the below example, Default is the applied view.



Select or unselect a view by clicking on it in the list.


Individual Settings

Changing the tree view settings yourself is done by right-clicking on an item in the structure tree, selecting View and choosing which items to display under the selected item. Any modifications that you make are only visible to you and only applied to the selected item and its sub-items.



Items that are selected to display will either have a checkmark (as with Datatype list in the below example) or a light-blue background applied to its icon (as with Unallocated design below) in the View menu: 


Hidden items, i.e., not selected to display, will appear unchecked or without a light-blue icon background.



If you want to select more than one part type at the same time, right-click on an item in the structure tree and left-click on View. The Select part types dialog will appear and you can multi-select or multi-deselect by using the provided checkboxes.



 As a rule, avoid turning on (i.e., set as viewable) the Description References and References in a structure as doing so can result in an extremely long load time for the structure and, potentially, an Out of Memory message. 


If all items are set to hidden, the selected tree item will not display its usual Expand tool. In the below example, all of the items under Software have been hidden in the current tree view:



When you modify a predefined structure tree setting, its name will appear with a "(modified)" suffix. In the above screenshots, the existing setting that was modified, i.e., "Default", now appears as "Default(modified)". Your "Default(modified)" option will remain applied for the current and future sessions. To return to one of the predefined global settings, use the global settings drop-down. 


Note: The ability to formally save modifications to create a new setting or modify an existing one that can be selected for future use is only available to users with the SystemWeaver Architect role.


The Structure Tree Item Menu

A mouse menu that includes View, Edit and Status tools is available by left-clicking on an item in the tree. Many of these options are also available in the Items tab ribbon which will be discussed more in The Menu Tabs and Ribbons section below.


Tip: Multiple items can be selected simultaneously by clicking while holding down the Shift key (for selecting adjacent items) or Ctrl key (for selecting non-adjacent items) which allows you to batch apply some actions making it a true time-saving tool. The number of items selected will be indicated in the view pane header.


The Header Menu

If you right-click on a column header in the header row of the structure tree, and throughout the site in tree and grid type views, the header menu displays with options to add additional columns to the view:


The following options can be of special relevance to the structure tree:

  • Name lists the Part name of the part. In case no part name is set, it lists the item name. The option is active by default.
  • Issues Last Changed lists the Last Changed property of the issue last changed for the item.
  • Notes Last Changed lists the Last Changed property of the note last changed for the item.
  • Primary Attribute adds a column where the Primary attribute (if any) is listed for each item.

The Expert Add field column lets you add an additional column to the current header row. 

The Export sub-menu includes various options to Export to Excel.


The Indicator Column

The left-most column in the structure tree is an indicator, or traceability column. This column can be used by views to indicate specific items in the structure. In the screenshot below, the items counted in the selected "Test" pie slice are indicated in the tree with the corresponding blue color.



If there are indications under a collapsed structure, the indicator column will include the number of total occurrences in the collapsed structure.


Sorting

In the structure tree, and throughout the site in part and grid views, sorting is available by clicking on a column header. The sorting is alphanumerical, rather than alphabetic/lexicographic. This means for example that the string "Top 20" will be ordered before "Top 100". For grid or tree type views, sorting is selected in a "cyclic" fashion: first click to sort descending, second click to sort ascending, third click returns to unsorted. The sorting order is indicated by a small arrow symbol in the header.



Shortcut To Sub-item Overview

You can view the Overview of a sub-item without having to load it to the specification view by clicking on it while holding down the Alt key. 


In the above example, Software is the selected item that is displaying the Issues view. ParkingBrakeCtrl was clicked with Alt to view the Overview view on-the-fly. 


The Specification View

The specification view shows information about the item that is selected in the structure tree.  There are about 100 different views available to chose from and, depending on the situation, some are more applicable than others. Often, users are instructed to use the views that are most helpful to them based on their tasks. Regardless, when you log in and select an item in the structure tree, the default view for that item type appears in the view pane as a tabbed page (A). You can change your view at any time by selecting a new one in the View drop-down list (B) or by selecting an available view option on the Items ribbon. Because the view options are so numerous and their content is driven by their item type which will always display to the far right (C), they will not be covered here. You can find details on the various views in the Views section of the Help or in other articles. In general, being aware of the item type of a selected item is useful throughout the site.


The Page Tab

As described above, when you open an item, a page with a tab appears underneath the menu ribbon in the view pane. If you have multiple items open simultaneously, all of the page tabs will display regardless of which page you are currently viewing. The active tab appears white while the tabs for inactive pages appear gray. 


Moving Tabs

Move a tab by selecting it, and then dragging it to the desired position among the open tabs. 


If a large number of pages are open, it may be difficult to view the complete item names on the tabs which makes navigating between them somewhat difficult. To help with this, click on theicon to the far right to easily find and select an item:



The Tab Menu

Left-click on a page tab to access the tab context menu. It provides the tools to close pages and/or add them to a Favorites list

To close an active tab, select Close. You can also click on thebutton to the right of the line of tabs or press Ctrl+W. When you close a tab, the last used tab will become active.


The Close other tabs option will close all tabs except the selected one.


Tip: To close an inactive tab, you don't have to select (left-click) it and load its content to the view. A quick shortcut is to just right-click the tab, and select Close.


Closed pages will appear in the 'Recently closed' list seen in the Open Item page: 



The Add to favorites option enables you to add frequently used pages to the Favorites list in the Open item menu. 


The Menu Tabs and Ribbons

The menu tabs and their ribbons contain the menus and options available in SystemWeaver. A ribbon will display the standard tools and view shortcuts available for the Item type selected in the structure tree, i.e., the active page loaded and the site role you have been assigned. Therefore, its look and available capabilities will change since some options are available to all items types and all users while others are specific to a specific item type or user role. A ribbon does not contain a complete selection of views. For that, use the View drop-down as described above in The Specification View. This section will give a brief description of each standard menu tab and its corresponding ribbon. For a more detailed explanation of each menu option's functionality, refer to the Help or other articles if needed. 


Note: Module-specific tabs and ribbons, e.g., Design, Documents, etc., are not covered here. You can find details on module-specific menus in the Help or in other articles.


Standard Tabs and Ribbons

File Tab

The File tab is used for general settings and user options.


Groups

Opens the Groups Setup dialog, where you can see all user groups and users in the server.


Configure the explorer

Opens the Configure the Explorer dialog, where a SW Architect can add and configure views and features available in the swExplorer. This menu item is hidden for non-SW Architect users.


New project

Create a new SystemWeaver Change Management System (CMS) Project, using the New Project dialog.


Delete project

Delete CMS projects. Note that only empty projects can be deleted, i.e., projects without any issues.


Logout

Logs you out from the server, just like the option on the Welcome tab.


Options

Opens the Options dialog where you can set personal user account options for the swExplorer.


Exit

Logs you out and closes swExplorer, just like the Close button in the Title Bar.


Welcome Tab

The Welcome tab is where you log in and see information about your SystemWeaver environment.


Home    
This is the start page for your SystemWeaver experience, and where you login to the SystemWeaver server. Also typically displays general information about your SystemWeaver environment. (The Home page of the browser can be configured by a system administrator.)

About
Displays version, 3rd party and extensions information about the swExplorer application that you are running.


Dashboard Tab

The Dashboard Tab presents an overview of your current activities and enables you to monitor them in one place:


My Last Changed

Displays your last 10 changes. 


Issues assigned to me

Displays the issues assigned to you by project.


Issues created by me

Displays the issues created by you by project.


Items Tab

The Items Tab organizes all of the pages where your development information is and enables you to interact with them. Which menu items that are available to you will depend on the type of item being viewed and sometimes even the context.


Navigation Menu


Back
Moves you to the previous location or locations, including switching the selected view to the one used for that location.

Forward
When you have used the Back button, the Forward button will be available, for going forward to the last position again.



Items Menu


Open Item
The starting point to find, open and start working with an item.
Tip: You can also access the Open Item page by pressing Ctrl+T.

New Item
The New item page is the place where new items are created (Unless the item is created in the context of another item, such as when a Part is created, using any of the Another or New options in the structure tree mouse menu.)



Edit Menu


Copy
Copy any selected item(s) - and available parts information to the clipboard.


Open
Open the selected item in a new tab.

Overview
Click to open the Overview view of the selected item. Other generic view options are also available for selection here.

Attributes
Click to open the Attributes view of the selected item.

Parts
Click to open the Parts view of the selected item. 



Find Menu


Find
The Find group includes several options for searching for items* within a context, like the structure tree or the Parts view.

Find next and Find previous
Once a search returns results, these buttons allow you to navigate through them.

Filter on search result
Will hide everything in the tree except the matching items from your search, and the item structure between them and the top item.


CM Menu


Versions
Opens the Versions view where you can get an overview of the version history of an item, change versions, and easily compare the different versions.

Status
Opens the Status view where you can get an overview of the status of the selected item and its use in the entire structure tree.

Completed Status
Opens the Complete Status view where you can review the status of every item in the item structure of the selected item.



Issues and Notes Menu


New issue
Opens the New issue dialog where you can create a new issue for the selected item or items.

Issues
Opens the Issues view where you can get an overview of all issues of the selected item.

Add Note
Opens the New note dialog where you can create a new note for the selected item.

Notes
Opens the Notes view where you can view and add notes for the selected item.


Security Menu


Libraries
Opens the Libraries view which gives you an overview of the libraries associated with items in the structure tree.

Move items
Opens the Select Library dialog where you select the new library for the selected item.

Manage libraries
Opens the Libraries page where you can manage libraries.


Project Tab

The Projects tab is where you manage SystemWeaver Change Management System (CMS) projects, aka simply as projects. 


Projects Menu


Projects
Opens the Select Project dialog where you can open an existing project.


Issues Menu


New issue
Opens the New issue dialog where you can create a new issue in the project.

Search in project
Opens the Find issues dialog where you can search for issues.

Open issue with Id
If you know the Id number of an existing issue, you can open it here.


Dynamic Layout

The layout of a menu group is dynamic and will change depending on the available space in the ribbon. If the window is made smaller, or new menu groups appear, all groups will adapt. Note that all options are still available in the group, despite the different arrangements. In the figure below we can see how the Edit menu adapts, until it becomes just a menu structure:


Minimizing the Ribbon

The ribbon can be minimized by double-clicking on any of the main tabs (File, Welcome, etc.) or by clicking on the small Collapse the Ribbonbutton at the far right end of the ribbon. To bring the ribbon back, double-click a tab again. To bring the ribbon back temporarily, click on the tab you wish to view.


Tip: In addition to the ribbon, you may also find additional options in right-click menus (a.k.a context menus) in many views.


Note:  Users with the SW Architect role have the option to define custom ribbon tabs. See the Configure ribbon tabs section of the Help.


Title Bar


The title in the above example begins with "Variability demo database", which is the name of the main library of the SystemWeaver database. An appropriate name of this library can be used for easy identification of the connected SystemWeaver server. The name of the SystemWeaver server computer is shown within brackets [ ] ("sys60" in the example). "SystemWeaver Collaborative Environment" is the window title of the swExplorer application.


Button
Description

The Help button opens the SystemWeaver Help manual.
 
The Ribbon Display Options button allows you to auto-hide the ribbon, show the tabs only or show the tabs and ribbons at all times.

The Minimize button minimizes the application window, i.e., removes it from the screen. Clicking on the icon in the Windows taskbar restores the window.

The Maximize button maximizes the application window on the screen. In the maximized window the Restore Down button can be used for restoring the size. The window is also restored if you drag the application window.

The Close button closes the application.



Status Bar

The status bar is the deep-blue colored bar at the bottom of the application window. The left part of the row displays information such as the status of the last operation or any exceptional event in the server. The right part of the bar displays extended hints for any operation you try to do.

Example: 


What's Next?

If you are new to SystemWeaver, we recommend Introduction to the SystemWeaver Meta Model. Otherwise, you can find out more about SystemWeaver Explorer functionality including keyboard shortcuts and much more by browsing through the SystemWeaver Explorer - Basic Tutorials and User Guide or the swExplorer Reference Manual section of the Help.