Start a new topic

"Error loading session" when opening Baseline Architecture

One of our users get an error message when opening the "Baseline Architecture" (which is the tree structure where all our data is stored). It reads "Error loading session" as a heading and "Out of memory" as a subsection. See attached picture. After this the tab is empty. It is possible to open other tabs.

There was an problem before that looked the same or similar, but at that time it was possible to change the view to "Default view" which solved the problem. This time the view selector is not shown at all.

1 Comment

Hi Johan,  

There are a couple of possible causes.

The user may have "Description References" set to view in a structure tree. As a rule, users should avoid turning on (i.e., setting as viewable) the Description References and References in a structure as doing so can result in an extremely long load time for the structure and, potentially, an Out of Memory message. In this example, "Description References" are not being displayed in the tree:

Have the user check to be sure that Description References and References are not turned on anywhere in a tree, especially large structures. You can check this easily by using Complete Part Types: View All Parts. Since you brought up "change the view to "Default view" which solved the problem ", we suspect this is likely the cause. If an Architect user has saved a structure tree setting that includes viewing Description References, we recommend that they remove that from the saved tree setting view (Configuring Tree View Settings). 

You'll also want to make sure that the user has, preferably, a minimum of 4 GB RAM (see SystemWeaver Client - System Requirements). It's likely that they have that though. It's possible that there are structures in the system that exceed the memory allowance of a 32-bit Windows process when performing certain operations, e.g., exports, and utilizing certain views, e.g., Versions view. If that is the case, they could consider opening the portion of the structure that they are working with rather than the entire baseline architecture. 

We have created a support ticket for your problem and will follow up directly with you via the ticket.  

Best regards, 

Systemite support

Login to post a comment